Divi en WordPress 5 – Gutenberg ya está aquí

Divi en WordPress 5 – Gutenberg ya está aquí

Desde hace unas semanas WordPress se ha actualizado a la versión 5, muy esperada por todos los usuarios debido a los cambios que trae consigo. Y es que con la llegada de Gutenberg la forma de crear paginas en WordPress de forma nativa cambia ya que afecta a muchos de los usuarios que usamos constructores visuales para construir o diseñar nuestras páginas web y, por supuesto, Divi no podría ser la excepción.

En el presente artículo te informaré de todo lo que debes saber como usuario Divi para usarlo en WordPress 5 sin ningún problema.

Contenido

  • ¿Es Divi compatible con WordPress 5?
  • ¿Como usar Divi en WordPress 5?
  • Desactivar el nuevo editor de bloques en las opciones de Divi
  • Tengo un sitio terminado ¿debo actualizar si o no?
  • Conclusiones

¿Es Divi compatible con WordPress 5?

Sí, pero a partir de las versión 3.18 esta versión aborda muchos problemas de compatibilidad con el nuevo editor llamado Gutenberg dentro de WordPress permitiendo alternar entre él y el editor Divi Builder.

Esta actualización también resuelve problemas con el nuevo sistema de meta box, que se usa para mostrar la configuración de la página Divi y las opciones de formato de publicación.

Además, se ha ampliado la compatibilidad con nuevos formatos de entrada para tener en cuenta los nuevos tipos de contenido de Gutenberg (como bloques de vídeo y audio).

Puedes actualizar tu tema y actualizar sus complementos utilizando el sistema de actualización estándar de WordPress. También se deberá ingresar el nombre de usuario y clave de API en los paneles de opciones de temas y complementos.

Si no has recibido una notificación de actualización o tienes problemas para actualizarla, puedes descargar las últimas versiones del producto desde el área de miembros de Divi y cargarlas manualmente.

Sigue aprendiendo con los cursos de la Zona Premium. Puedes darte de alta por 10€ al més aquí.
Incluye acceso a los cursos, descargas de temas, plugins premium y soporte directo conmigo para dudas.

¿Como usar Divi en WordPress 5?

Una vez que creamos una nueva página o editamos una existente en WorpPress 5 con Divi instalado nos aparecerá el editor Gutenberg junto al típico aviso de Divi para poder seleccionar qué editor usar para crear nuestra pagina pagina web.

seleccionar editor wordpress

Al seleccionar el editor de Divi nos aparecerá el editor de Divi que ya conocemos.

Elegant Themes ha planeado tres etapas adicionales de compatibilidad para las próximas semanas, y las formas en las que Divi se integra e interactúa con Gutenberg serán más avanzadas y más fluidas en un futuro.

Desactivar el nuevo editor de bloques en las opciones de Divi

Existen dos formas de hacerlo, una usando un plugin y otra usando solo Divi veámoslas ahora:

Plugin Classic Editor

Este plugin nos permite traer de vuelta el editor clásico de WordPress y con él poder usar versiones de Divi antiguas haciendo que WordPress y el Divi Builder funcionen tal como lo hacía antes de actualizar a WordPress 5.0.

Puedes usarlo todo el tiempo que necesites para familiarizarte con el nuevo sistema, y Divi seguirá siendo compatible tanto con el editor clásico como con el nuevo editor de Gutenberg. Para descargarlo en el buscador de plugins de WordPress Búscalo por su nombre:

descargar plugin classic editor

Lo instalaremos y activaremos como de costumbre y después iremos a Ajustes > Escritura. Asegúrate de que el editor clásico está configurado como tu editor por defecto.

habilitar editor clasico

Puedes usarlo todo el tiempo que necesites para familiarizarte con el nuevo sistema, y Divi seguirá siendo compatible tanto con el editor clásico como con el nuevo editor de Gutenberg.

Usando Divi

Otra opción es también desactivar el nuevo editor de bloques de WordPress y activar el editor clásico dentro de las opciones de Divi.

Si estás utilizando WordPress 5.0 o superior, aparecerá una nueva opción en Divi > Opciones del Tema > Builder > Avanzado. Solo basta con habilitar o deshabilitar la opción Enable Classic Editor y guardar los cambios.

cambiar opciones de tema

Si tengo un sitio terminado ¿debo actualizar si o no?

Todo lo que hemos visto hasta ahora es perfectamente válido si apenas comenzamos a crear nuestra página web usando Divi en WordPress 5. Sin embargo, si ya tenemos una web completamente terminada y funcional en Divi inferior a la versión 3.18 y en WodPress inferior a la 5 surge la gran pregunta. ¿Debo actualizar mi sitio a WordPress 5?

Y mi respuesta sería no, o al menos no ahora, si tienes tu página en producción como un blog, un sitio corporativo o una tienda en línea espera al menos a la primer quincena de febrero. Ten en cuenta que WordPress 5 como todas las piezas de software nuevas requieren o que han sufrido cambios importantes en su estructura requieren de tiempo para los desarrolladores detecten errores y los corrijan así como diversas incompatibilidades que seguramente irán surgiendo.

Además, darás tiempo para que los plugins y temas más usados se vayan adaptando a WordPress 5. No te olvides de hacer copias de seguridad para que cualquier error producido por estos importantes cambios sea fácil de restaurar.

Sin embargo, si aun así decides actualizar tu sitio te recomiendo que lo hagas de la siguiente forma para minimizar posibles incidentes:

  1. Antes que todo haz una copia de seguridad de tu sitio, te recomiendo usar All In One WP Migration.
  2. Actualiza el tema Divi ya se de forma manual o automática recuerda mínimo a la versión 3.18.
  3. Actualiza los plugins que tengas instalados ya se de forma manual o automática. Te recomiendo ver las notas de instalación de cada plugin para asegurarte que serán compatibles con WordPress 5 y si fuere el caso con Gutenberg.
  4. Actualizamos a WordPress 5.0.
  5. Determina si usaras el editor nuevo o volverás al clásico, esto en caso que no tengas una versión de Divi 3.18 o superior.
  6. Probamos cómo luce la página principal de tu sitio y fuera necesario hacer los cambios pertinentes. Finalmente, repite esto para todas las páginas o entradas del sitio.

Conclusiones

WordPress en su versión 5 y Gutenberg traen consigo cambios importantes en la forma de construir nuestros sitios, si eres un usuario con versiones antiguas de Divi y deseas actualizar a WordPress 5 puedes volver al editor tradicional usando el plugin Classic Editor. Sin embargo, es recomendable esperar para actualizar al menos a la segunda quincena de febrero para usar un WordPress 5 más optimizado y con menos errores.

Una cosa es segura, Gutenberg ha venido para quedarse como editor por defecto de WordPress por lo que cuanto más pronto te acostumbres a él mucho mejor. Pronto en davidibiza.com tendremos un curso premium para enseñarte a usar por completo y desde cero Gutenberg,el nuevo editor de WordPress

Sigue aprendiendo con los cursos de la Zona Premium. Puedes darte de alta por 10€ al més aquí.
Incluye acceso a los cursos,  descargas de temas, plugins premium y soporte directo conmigo para dudas.

¿Quieres aprender más WordPress?

Suscríbete y recibe mis mejores contenidos en tu email

No te pierdas nada :)

Muchas gracias por suscribirte. Tendrás noticias mías por correo en breveRevisa, por favor, tu bandeja de spam o correo no deseado si en unos minutos no has recibido mi email.¡Seguimos!​David